If you have a problem or need to report a bug please email :

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

Can't open a COM Port. (Solved)

For general discussion related FlowStone

Can't open a COM Port. (Solved)

Postby mockba » Mon Nov 01, 2010 7:28 pm

Hi there,

Maybe I am missing something here, but for some reason I can't open a COM port using Flowstone.
Did anyone ever experience this?

I have a USB->UART LCD Module from Sure Electronics connected to my laptop, wich ended up on COM11, but every time I open Flowstone, when I try to connect to the port I first get "Failed to set configuration for port" then it changes to "Com11:Failed" and stays like this every time I try to open it.
If I connect to the module using Putty it works fine, so I guess the COM11 and the module are working fine.
I have tried also a serial adapter on my office's laptop, this time on COM5, same thing.
Also I have a modem on both laptops, both on COM3, same thing.
So either I am doing something wrong or something is broken.
I have searched the forum and I see people also having the same problem, but the conversations usually move towards other subjects and nobody seems to give a direct answer for any of these questions:

1 - Does a COM port higher than COM1 work on Flowstone?
2 - Is there any special configuration to use a COM port higher than COM1?

I am just using the standard 9600-8-n-1 on the COM module, nothing fancy here.

Please let me know if anyone here has had any degree of success on this.

Thanks a lot,
Last edited by mockba on Tue Nov 02, 2010 5:59 am, edited 1 time in total.
Posts: 6
Joined: Wed Aug 18, 2010 5:18 am

Re: Can't open a COM Port.

Postby DSP » Tue Nov 02, 2010 1:20 am

I've used lot's of different com ports with FlowStone with no problems (Com5-Com10). Also different devices, some USB-COM port adapters, some Relay boards with the FTDI chip etc.

One silly thing I did was set the Stop bits wrong as on the Comport module it an Int in so:

0 = 1
1 = 1.5
2 = 2
Posts: 150
Joined: Fri May 14, 2010 10:55 pm

Re: Can't open a COM Port.

Postby mockba » Tue Nov 02, 2010 5:57 am

See? I knew it should be something dumb I was doing ...

Posts: 6
Joined: Wed Aug 18, 2010 5:18 am

Return to General

Who is online

Users browsing this forum: DaveyBoy, Majestic-12 [Bot] and 22 guests