Support

If you have a problem or need to report a bug please email : support@dsprobotics.com

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

Vanishing Ruby labels

For general discussion related FlowStone

Vanishing Ruby labels

Postby k brown » Tue Jun 30, 2020 5:02 am

This is a new one on me - upon changing a Color prim on one of the states of a Ruby selector, the schematic froze for a few seconds and upon recovering, there were Ruby error stripes all over the place, and every Ruby label in the whole schematic, except for a single module, disappeared. Closed the schematic and re-opened, still gone; no more Ruby error warnings, but all labels still gone; plus text in the Ruby selectors. ?

FS 3.0.6.

UPDATE - I realized that all the Ruby modules turned themselves off. Manually turning them back on restores the labels, but is there some way to send a global command that will turn them all back on, or is it really a matter of slogging through the whole bloody schematic and turning them all back on one by one? :shock: :(
k brown
 
Posts: 1014
Joined: Tue Aug 16, 2016 7:10 pm
Location: San Francisco, CA USA

Re: Vanishing Ruby labels

Postby trogluddite » Tue Jun 30, 2020 2:38 pm

No, there's no "global reset", sadly. :(

In later FS versions, there was a fix to stop Ruby shutdowns from spreading across the schematic; but unfortunately, the cure was worse than the disease (memory leaks and much greater Ruby CPU load).
All schematics/modules I post are free for all to use - but a credit is always polite!
Don't stagnate, mutate to create!
User avatar
trogluddite
 
Posts: 1706
Joined: Fri Oct 22, 2010 12:46 am
Location: Yorkshire, UK

Re: Vanishing Ruby labels

Postby k brown » Wed Jul 01, 2020 7:58 am

Ouch !!
k brown
 
Posts: 1014
Joined: Tue Aug 16, 2016 7:10 pm
Location: San Francisco, CA USA


Return to General

Who is online

Users browsing this forum: Google [Bot] and 26 guests