If you have a problem or need to report a bug please email :

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

Help setting up PhantomX Reactor Robot Arm

Discuss robotics applications using FlowStone here

Help setting up PhantomX Reactor Robot Arm

Postby tdube » Fri Mar 01, 2013 1:16 am


We recently bought the PhantomX Reactor Robot Arm Kit, after assembling it I am trying to get it to work but no luck so far. I pretty much followed the instructions to download Flowstone, arbotix & arduino, after uploading the firmware as mentioned in this link, i was able to get some response from the arm using

When i run pypose in terminal mode this is what I am getting:
>> valid commands
>> ls
1 2 3 4 5 6 8
>> pos
>> baud
>> temp

Other than ls no other command is responding. i would really appreciate if some one could throw some light on what I am doing wrong?

Thanks in advance for your help.

Posts: 2
Joined: Thu Feb 28, 2013 8:48 pm

Re: Help setting up PhantomX Reactor Robot Arm

Postby tdube » Fri Mar 01, 2013 10:18 pm

Hi All,

After loading the Arbotix robocontroller sketch from : ..., when I power on the arm it goes to its home position, but when I run pypose & select the com port, the arm moves for about a second & then comes back to its home position. If I type ‘ls’ it returns “Fail Read” for all the 8 servos.
On the Flowstone UI at the bottom left corner I see an error message “Error Inside Module” if I press the play/record button. There is no hand movement.

I also noticed that servo# 2 & #3 have blinking red lights and they don't seem to be moving when I power on the arm. Does this mean that they are not programmed correctly?

Not sure whats wrong, any help is highly appreciated.

Thanks & Regards
Posts: 2
Joined: Thu Feb 28, 2013 8:48 pm

Re: Help setting up PhantomX Reactor Robot Arm

Postby trogluddite » Sat Mar 02, 2013 12:26 am

Hi Tanmoy,

Thought I would welcome you to the forum - wouldn't want you to think we were ignoring you!
Unfortunately the forum is rather dominated by audio/synth DSP freaks like me just at the moment, which is probably why you haven't had an answer yet.

Are you using the software within FlowStone? I am not sure if maybe there is a stand-alone version that can be used without needing FlowStone.
The error message you see on the GUI indicates that there is some Ruby code somewhere inside the software that is not happy. If you are using FlowStone, you might be able to click the border of the main GUI to see the parts inside - if so, there will be a block inside showing the same error. You can then follow the trail of red "error" modules, and will eventually come to a block of code somewhere with a full error message at the bottom of it. If you are able to see that, maybe the error message will give us a clue what the problem is.
My guess is that something is not quite right with the serial port communication - but I must stress, I know nothing of controlling robot hardware, so that is just a wild guess!!

In case anyone else here is wondering what this is all about - Tanmoy's arm is the one supported by the special FlowStone Robot Arm software posted on the forum a while back. (LINK)
All schematics/modules I post are free for all to use - but a credit is always polite!
Don't stagnate, mutate to create!
User avatar
Posts: 1521
Joined: Fri Oct 22, 2010 12:46 am
Location: Yorkshire, UK

Return to Robotics

Who is online

Users browsing this forum: No registered users and 1 guest